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Alibre Design - Part Modeling Tutorial 1  
 

Introduction 
 

This tutorial guides you through the creation of your first part using Alibre Design.  It is 
assumed that you have already read Alibre Design - Modeling Fundamentals before starting this 
tutorial.   
 
You will be creating this simple part: 
 
 

    
Enclosure 

 
 
This tutorial will cover: 
 

� Opening new part workspaces. 
� Setting workspace properties. 
� Creating sketches. 
� Creating a base feature with a boss. 
� Creating a hole feature. 
� Creating a fillet feature. 
� Creating a shell feature. 
� Creating a feature pattern. 
� Modifying sketches and feature properties. 
� Modifying part color properties. 
� Saving parts to the Repository. 

 
 
 

Starting Alibre Design 

 
1 From the Windows Start menu, click Programs, Alibre Design. 

 
The Alibre Design Launcher window appears. 

 
2 Click either Work Offline or Connect Now to launch Alibre Design; sign on if you 

want to work online.  You can complete this tutorial working offline or online. 
 

The Alibre Design Home window appears. 
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Opening a New Part Workspace 
 

1 To open a new part workspace, on the Home window, from the File menu, select 

New > Part, or click the New Part  icon on the main toolbar. 
 

A new part workspace appears. 
 
 
 

Setting the Workspace Properties 
 
Before you begin, set the following workspace and design properties.  These specific options are 
not required, but may make sketching and modeling tasks easier to learn.     
 
Design Options 

 
1 In the part workspace, from the Tools menu, select Options.   

 
The Options dialog box appears. 
 

2 Click the General tab if it is not already selected. 
 

3 In the Design options list, select the following options: 
 
   

      
 

4 Next, click the Grid tab, and unselect the Display Grid and Snap to Grid options. 
 

5 Click OK to apply the settings and close the Options dialog box. 
 

 
Units and Dimensions 

 
1 In the part workspace, from the File menu, select Properties.   

 
The Design Properties dialog box appears. 
 

2 Click the Units tab if it is not already selected. 
 

3 In the Display Units area, make sure that: 
� Units is set to Inches 
� Format is set to Decimals 
� Precision is set to 3   

 
4 Also, click the Show Units for Dimensions box.  All other settings and default values 

in the Units tab are acceptable for this tutorial. 
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5 Next, click the Dimensions tab. 
 
6 Check the Show Equations option.  All other settings and default values in the 

Dimensions tab are acceptable for this tutorial. 

7 Click Apply.   

8 Click Close.  
 
 
 
Modeling the Enclosure 
 
Sketching a Rectangle  
 
The first feature in the design is known as the base feature.  The base feature in this part is a 
rectangular extrusion created from a square profile.  Begin by sketching a rectangle. 
 

1 Before you begin sketching, first select the XY-Plane to set it as the working plane.  To 

select the XY-Plane, click the Select  tool on the View toolbar and then click XY-
Plane in the Design Explorer on the left side of the workspace, or click on the XY-Plane 
in the work area.   
 
The XY-Plane turns yellow after you select it (The colors described in this tutorial are 
based on using the Dark Background color scheme.  To change the color scheme, from 
the Tools menu, select Options, then the Color Scheme tab). 

 
Note: When you move your cursor over an icon in a toolbar,  
a label displays the tool name. 

  
   

 

2 To enter sketch mode, select the Sketch Mode  tool on the Sketching toolbar.  The 
work area view reorients so that the XY-plane is parallel to the screen. 

 

3 Select the Rectangle by Two Corners  tool on the Sketching toolbar.  The cursor 

changes to . 
 

4 Click once in the upper left quadrant of the working plane to start sketching the 
rectangle.  (Most sketching operations are performed through a series of mouse clicks 
and cursor movements; typically, click and release to initiate an operation, move the 
cursor to size or position, and click and release again to complete the operation). 

 
Note: Hints are displayed in the lower left corner of the workspace and describe how to 
start or complete an operation.  For example, you will see “Pick start point” and “Pick 
the point for the width and height.  ESC to quit” as you sketch the rectangle. 
  

5 Move the cursor to the lower right quadrant of the working plane.  You will see a preview 
rectangle as you move the cursor. 

 
6 Click again in the lower right quadrant of the working plane to complete the rectangle.  

The resultant sketch contains blue sketch figures (e.g. lines), green sketch nodes (e.g. 
end points), and green constraint symbols.     
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Note: If you make a mistake while sketching, you can use the Undo tool  on the 
Main toolbar, or from the Edit menu, select Undo, to undo the last operation. 
 
 

Placing Dimensions on the Rectangle 
 
Now specify the size of the sketched rectangle by adding dimensions. 

 

1 Select the Dimension  tool on the Sketching toolbar, or from the Sketch menu, 

select Dimension.  The cursor changes to . 
 
2 Move the cursor over the left vertical line of the rectangle, the line turns red.   

 
3 Click once on the line, a dimension appears. 

 
4 Move the dimension to the left of the vertical sketch line. 

 
5 Click once to place the dimension.  The dimension control box appears.   

Enter a value of 5.0 in the box and press Enter.       
 

6 The dimension is displayed. 
 

7 Move the cursor over the top horizontal line of the rectangle, the line turns red. 
 

8 Click once on the top horizontal line, a dimension appears. 
 

9 Move the dimension to the top of the horizontal line. 
 

10 Click to place the dimension.  The dimension control box appears.  Enter D1 in the box 
and press Enter.  By entering D1, you are ensuring that the length of this line will 
always be equal to the length of the first vertical line you dimensioned.  If you change 
the value of D1, D2 will automatically change. 
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Applying Manual Constraints on the Sketch  
 
Center the sketch about the origin by manually placing constraints on the sketch. 
 

1 On the Sketching toolbar, click the small black arrow  under the Parallel Constraint 

 tool; the constraint toolbar appears. 

 
 

2 Select the Symmetric Constraint  tool from the constraint toolbar.  The cursor 

changes to . 
 

3 To apply the first constraint, click the Y-Axis in the work area or the Design Explorer, a 
green reference line appears on the axis. 

 
4 Click the left vertical line, the line turns yellow. 

 
5 Click the right vertical line.  The vertical lines are now constrained symmetrically about 

the Y-Axis and two symmetric constraint symbols appear. 
 

6 To apply the second constraint, click the X-Axis in the work area or the Design Explorer, 
a green reference line appears on the axis.  

 
7 Click the top horizontal line, the line turns yellow. 

 
8 Click the bottom horizontal line.  The horizontal lines are now constrained symmetrically 

about the X-Axis and two additional symmetric constraint symbols appear.  
 
  
 
Sketching a Circle 
 
Next, sketch a circle within the existing square. 
 

1 Click the Circle  tool on the Sketching toolbar.  The cursor changes to . 
 

2 Move the cursor over the origin.  The origin turns red and the cursor changes to . 
 

3 Click to place the center of the circle at the origin. 
 

4 Move the cursor away from the origin; you will see a blue preview circle as you move 
the cursor. 

 
5 Click to place the edge of the circle within the original square sketch. 
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Placing a Dimension on the Circle 
 
Place a dimension on the circle to define its size. 
 

1 Click the Dimension  tool on the Sketching toolbar, or from the Sketch menu, select 

Dimension.  The cursor changes to . 
 

2 Click the circle, a diameter dimension appears. 
 

3 Move the dimension away from the circle. 
 

4 Click to place the dimension, the dimension control box appears.   
 

5 Enter a value of 2.5 in the box and press Enter.   
 
 
 
Adding Fillets to the Sketch 
 
Now finish the sketch by placing fillets on the four corners of the square. 
 

1 Click the Fillet  tool on the Sketching toolbar, or from the Sketch menu, select 
Fillet. 

The Fillet Figures dialog box appears and the cursor changes to . 
 
2 Click the left vertical line; the line turns yellow and is listed in the Figures to Fillet area 

in the dialog box. 
 

3 Hold the Shift key and click the top horizontal line.  The line turns yellow and is listed in 
the Figures to Fillet area in the dialog box. 
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4 Change the Radius value to .500” if it is not already set. 
 
5 Click Apply to create the fillet but do not close the dialog box.  

 
The fillet appears with a .500” radius.   

 
6 Repeat steps 2-5 to place fillets on the remaining three corners of the square.  

Remember to hold the Shift key as you select the second line. 
 

7 Click Close on the Fillet Figures dialog box when finished.  The sketch is now complete. 
 
 

 
 
 

8 To exit sketch mode, click the Sketch Mode  tool on the Sketching toolbar, or click 

the Select  tool on the View toolbar.  The sketch changes from blue to yellow, and 
the dimensions and green nodes and constraint symbols are no longer visible. 
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9   After you exit sketch mode, the completed sketch is listed in the  
Design Explorer as Sketch<1> under the Features node. 

 
 
 
 
 
 
 

Note: You can edit sketches at anytime.  To edit a sketch, double-click the sketch in the 
Design Explorer, or right-click the sketch and select Edit from the pop up menu.  

 
 
 
Creating the Base Feature 
 
The first feature in any part is called the base feature.  Create the base feature in this part by 
extruding the sketch created in the steps above. 
 

1 To create the base feature, click Sketch<1> in the Design Explorer. 
 

2 Select the Extrude Boss  tool on the Part Modeling toolbar, or from the Feature 
menu, select Boss > Extrude. 

 
The Extrude Boss dialog box appears and the view changes to isometric displaying a 
preview of the extrusion. 

 
3 Under Type, select Mid-Plane. 
 
4 Change the length value to 10”.   

 
5 Click OK to create the extrusion.  The extrusion appears. 

 

6 If you need to zoom out to see the entire model, click the Zoom to Fit  tool on the 
View toolbar.  

 
7 The new feature is listed in the Design Explorer as Extrusion<1> under the Features 

node.  Sketch<1>, which you used to create the feature, is now listed under 
Extrusion<1>. 

 
 

 
 
 
 

Note: You can edit the properties of a feature (e.g. type, length, etc.).  Right click on 
the feature in the Design Explorer and select Edit from the pop up menu. 
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Saving the Part 
 
Save the work you have completed up to this point.  
 

1 Click Save  on the Standard toolbar, or from the File menu, select Save. 
 

The Save dialog box appears. 
 

2 Click your local repository. 
 

Note:  You save, manage, and share files using the repository system.  Local 
repositories reside on your system’s hard drive.  Repositories can also be created 
remotely on other hard drives you have access to on your network.  Learn more about 
repositories in the Alibre Design Help under Data Sharing and Management.  

 
3 Click New Folder, the New Folder dialog box appears. 

 
4 Type Tutorial in the New Folder dialog box. 

 
5 Click OK to create the Tutorial folder. 

 
6 Click the Tutorial folder. 

 
7 In the Name text box, type Enclosure. 

 
8 In the Save as type list, select Alibre. 

 
9 Check Make new versions for all if it is not already selected. 

 
10 Click Save.  The Enclosure part is now saved in your local repository.   

 
 
 
Adding a Shell Feature 
 
After the base feature has been created, you can add more features to the part.  In this section 
you will add a shell feature which removes material from a selected face, leaving a thin-walled 
part. 

 

1 Click the Select  tool on the View toolbar, if it is not already selected. 
 
2 Move the cursor over the face on either end of the extrusion.  Since the part is 

symmetric, it does not matter which end you use. 
 

The face turns red when your cursor is over it, and the cursor  
changes to show that it is over a face.   

 
3 Click the face to select it, the face turns yellow. 

 

4 Click the Shell  tool on the Part Modeling toolbar, or from  
the Feature menu, select Shell. 
 

5 The Shell dialog box appears, and the Faces to remove area  
is populated with the face you selected. 
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6 Change the Standard thickness value to .25”. 
 
7 Click OK to create the shell feature. 

 
8 The new feature is listed in the Design Explorer as Shell<2> under the Features node. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Adding a Fillet Feature 
 
Add a fillet feature to the other end face.  The fillet feature will remove or round all the sharp 
edges associated with the face. 
 

1 Click the Select  tool on the View toolbar, if it is not already selected. 
 
2 Rotate the view so that the opposite end of the extrusion is visible.  To rotate, press 

both left and right mouse buttons and drag the cursor.   
 

3 Select the end face on the extrusion, the face turns yellow. 
 

4 Select the Fillet  tool on the Part Modeling toolbar, or from the Feature menu, select 
Fillet. 

 
5 The Fillet Edges dialog box appears, and the Entities to fillet area is populated with 

the face you selected.  
 

6 Change the Radius value to .5” if it is not already set. 
 

7 Click OK to create the fillet feature. 
 

8 The new feature is listed in the Design Explorer as Fillet<3> under the Features node. 
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Adding a Hole Feature 
 
Continue to define the shape of the part by adding a hole feature. 
 

1 Click the Select  tool on the View toolbar, if it is not already selected. 
 
2 Move the cursor over the end face that you used to create the fillet feature.   

 
3 Click the face to select it, the face turns yellow. 

 

4 Click the Hole  tool on the Part Modeling toolbar, or from the Feature menu, select 
Hole. 

 
5 The view reorients so that it is parallel to the screen, and a blue preview hole is 

displayed near the location you clicked on the selected face. 
 
   
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
The Hole Dialog box also appears, and the Start surface area is populated with the face 
you selected.  Drag the Hole Dialog box out of the way so it does not obscure the work 
area but do not close it. 

 
6 Place the center of the hole on the X-Axis by placing a coincident constraint on the 

sketch.  On the Sketching toolbar, click the small black arrow , the constraint toolbar 
appears. 

 
 
 
 
 

7 Click the Coincident Constraint  tool on the constraint toolbar.  The cursor changes 

to . 
 
8 To place the coincident constraint, move the cursor over the X-Axis and click, or click 

X-Axis in the Design Explorer, the X-Axis turns blue. 
 

9 Move the cursor over the green center node in the blue preview circle; the node turns 
red when the cursor is over it. 

 
10 Click the center node of the blue preview circle; the blue preview circle moves and is 

now constrained to the X-Axis. 
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11 To position the hole with respect to the origin, select the Dimension  tool on the 
Sketching toolbar, or from the Sketch menu, select Dimension.  The cursor changes to 

. 
 

12 Select the Y-Axis, a dimension appears. 
 

13 Move the cursor over the green center node of the blue preview circle, the node turns 
red. 

 
14 Click the center node of the blue preview circle, a horizontal dimension between the Y-

Axis and the center node appears. 
 

15 Move the dimension to a more visible area if necessary. 
 

16 Click to place the dimension, the dimension control box appears. 
 

17 Enter 1.875 in the control box and press Enter. 
 

18 The hole is now properly positioned with respect to the origin. 
 

19 In the Hole dialog box, under Type, select Simple. 
 

20 Under Depth Condition, select Through All. 
 

21 Change the Diameter value to .250”. 
 

22 Click OK to create the hole feature. 
 

23 The new feature is listed in the Design Explorer as Hole<4> under the Features node. 
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Creating a Pattern of the Hole Feature 
 
Next, create a circular feature pattern of the hole about the origin. 
 

1 Click Hole<4> in the Design Explorer to select it. 
 
2 From the Feature menu, select Pattern > Circular. 

 
The Circular Pattern dialog box appears and the Select Objects area is populated 
with Hole<4>. 

 
3 Click Circular Path Center in the dialog box.  The title appears in bold. 
 
4 Select the Z-Axis in the work area or the Design Explorer. 

 
Z-Axis appears in the Circular Path Center area. 

 
5 Change the Copies value to 8. 

 
6 Change the Angle value to 45°.  Blue preview circles appear showing the location of the 

patterned holes. 
 

7 Click OK to create the circular pattern. 
 

8 The new feature is listed in the Design Explorer as Pattern<5> under the Features 
node. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Changing the Part Color Properties 
 
Finish the part by adding color properties. 
 

1 From the Edit menu, select Color Properties, or right click in the work area and select 
Color Properties from the pop up menu. 

 
The Color Properties dialog box appears. 
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2 Click the Color button. 
 

The Color palette appears. 
 

3 Select a color by clicking a Basic Color, or create a custom color. 
 
4 Click OK. 

 
5 Slide the Opacity and Reflectivity controls to make the part semi-transparent and/or 

reflective. 
 

6 Click OK to apply the settings. 
 

7 Click  on the Standard toolbar, or from the File menu, select Save. 
 

The Save dialog box appears. 
 

8 Click Save.     
 
 
 
 
Additional Tasks 
 
The true benefits of parametric solid modeling are realized when changes or modifications to a 
part are required.  The steps below provide examples of how quickly and efficiently a part can 
be changed. 
 
 
Editing an Existing Sketch 
 
In the first section of this tutorial, you created a sketch that defined the profile of the Enclosure 
part.  You now edit the sketch and modify a dimension. 
 

1 In the Design Explorer, under the Features node, click the plus sign next to 
Extrusion<1> if it is not already expanded. 

 
2 To edit the sketch, double click Sketch<1>, or right click on Sketch<1> and select 

Edit from the pop up menu. 
 

3 The view reorients so that it is parallel to the screen, and you are now in sketch mode. 
 

You may need to zoom out to see all the dimensions associated with the sketch.  If you 

have a mouse wheel, use it to zoom out.  If not, click the Zoom Mode  tool on the 
View toolbar and zoom out until all the dimensions are displayed.    

 

4 Click the Select  tool on the Sketching toolbar.   
 
5 Move the mouse over any part of the D1 dimension, the dimension turns red. 

 
6 Double click on the D1 dimension, the dimension control box appears. 

 
7 Change the value in the dimension control box to 6.25 and press Enter. 

 
The sketch changes size but the part shape does not change. 



Alibre Design - Part Modeling Tutorial 1    
  

15 
 

8 Update the part by exiting sketch mode.  Click the Select  tool from the View toolbar. 
 

The part is regenerated and reflects the changes made to the sketch.  
 
 
 

Reordering Features Using the Design Explorer 
 
You can also quickly alter a part by changing the order in which features are generated.   
 

1 After completing the Enclosure part, the Features node in the Design Explorer lists five 
features.  

     
 
 
 
 
 
 
 
 
 

 
2 Click Fillet<3> and hold the mouse button down. 
 
3 While holding the mouse button down, move the cursor up the Features tree.  The 

cursor changes. 
 

 
 
 
 
 
 
 
 
 
 

 
 
 

4 Release the mouse button when the cursor is over Extrusion<1>. 
 
5 The Features order changes, Fillet<3> is now listed before Shell<2>. 
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The change is slight, but notice on the part that a fillet has been created on the interior 
edges at the bottom of the Enclosure.  This occurs because Fillet<3> is now generated 
before Shell<2>, and the fillet radius exceeds the shell wall thickness. 
 
 
This completes Part Modeling Tutorial 1.  You do not need to save the changes made in 
the Editing a Sketch and Reordering Features sections.  The Enclosure part will 
continue to be used in additional tutorials.  
 
 
 

 
 
 
 
 
 
Providing Feedback Related to this Tutorial 
 
Alibre, Inc. is committed to providing the highest quality documentation, and we welcome your 
feedback.  Please email us if you have comments or suggestions about this tutorial. 
 
Please include the following information with your feedback: 
 

1 Topic title 
 
2 Page number 

 
3 Brief description of content (for example, inaccuracies in step-by-step instructions, 

grammatical errors, information that requires further clarification or additional details, 
etc.) 

 
4 Your suggestion for improving/correcting the documentation 

 
 
Please direct your email message to: 
 
userexperience@alibre.com 
 
 


